openSUSE Tumbleweed - Revisão da semana 17 e 18 de 2018


Uma nova revisão do que aconteceu nas semanas 17 e 18 de 2018 no openSUSE Tumbleweed a versão “rolling release” de atualização contínua da distribuição de GNU/Linux openSUSE.

O anúncio original você pode ler no blog de Dominique Leuenberger, no link abaixo:

http://dominique.leuenberger.net/blog/2018/05/review-of-the-weeks-2018-17-18/


Mais uma vez, uma revisão abrangendo duas semanas - mas muitos recursos estão atualmente focados em tornar o openSUSE Leap 15.0 sólido, o que significa que alguns pacotes estão apenas tentando corrigir bugs conhecidos em vez de atualizar para novas versões que podem corrigir os bugs conhecidos, mas provavelmente também introduziu novos. Não que o openSUSE Tumbleweed seja rigoroso a ponto de aderir à cadência de upgrade do Leap. mas, como os mantenedores compartilham o peso de ambos os produtos, é natural que muitos tentem manter a diferença por enquanto. As últimas duas semanas viram 8 instantâneos do Tumbleweed do openSUSE: 0419, 0420, 0424, 0425, 0427, 0429, 0501 e 0502.

Os instantâneos continham essas atualizações dignas de nota:
  • KDE Frameworks 5.45.0
  • GNOME 3.28.1
  • Mesa 18.0.1
  • Kernels Linux 4.16.3 a 4.16.6
  • Aplicativos do KDE 18.04.0
  • LibreOffice 6.0.4.1
  • polkit 0.114 - baseado no motor Mozilla js 52 (17 anteriores)

Atualmente, os projetos de preparação contêm essas alterações maiores, algumas das quais podem precisar de ajuda (confira o painel):
  • GCC 8 como compilador padrão de distribuição (incl. Atualização para o GCC 8.1)
  • ICU 61.1 - O nodejs e o LibreOffice precisam de correções de compilação.
  • TeXLive 2018 final 20180414
  • Automake 1.16 [.1] - À medida que migramos de 1,15, os builds que implicitamente chamam o automake falharão; altere sua compilação para chamar explicitamente autoreconf (preparação quase pronta, somente libtool à esquerda)
  • FFmpeg 4 (com o ffmpeg 3.x permanecendo disponível por enquanto na distro)
  • Freetype 2.9.1: freetype-config não é mais enviado. configure scripts confiando nele deve ser reescrito para usar o pkg-config para encontrar a informação relevante
  • Plasma 5.12.5
  • Kernel Linux 4.16.7

Mantenha atualizado e você sabe: Divirta-se.