openSUSE Tumbleweed - Revisão da semana 48 de 2017

 
Uma nova revisão do que aconteceu na semana 48 de 2017 no openSUSE Tumbleweed a versão “rolling release” de atualização contínua da distribuição de GNU/Linux openSUSE.

O anúncio original você pode ler no blog de Dominique Leuenberger, no link abaixo:
 
 
Em algumas semanas, os instantâneos simplesmente caem de OBS e passam o QA  sem problemas, outras semanas causam um pouco mais de problemas e alguns instantâneos são descartados. Mas é exatamente para isso que temos OpenQA, não é? Assim, desde a minha última revisão, apenas 2 instantâneos viram a luz do dia: 1125 e 1129. Mas, como de costume, se houver uma lacuna, isso só significa que os problemas de um instantâneo estão sendo corrigidos no próximo até que ele esteja de volta em um estágio onde podemos liberá-lo para os usuários.
As mudanças importantes / interessantes que aconteceram nesses dois instantâneos foram:
  • Linux kernel 4.14.1 e 4.14.2 (sim, dois instantâneos, ambos trazem um novo kernel.
  • OpenSSL 1.1 agora é o padrão para a distribuição. Isso pode causar alguns problemas de atualização, especialmente se você tiver pacotes de desenvolvimento instalados. A recomendação é permitir que o zypper remova libopenssl-1_0_0-devel (para que ele possa atualizar para 1.1). Dependendo do que você está desenvolvendo, você pode obter outros problemas relatados (por exemplo, libQT4-devel, como o Qt4 não oferece suporte a openSSL1.1 e nunca será)
  • O sistema de compilação SCons agora usa python3 como intérprete. Isso pode causar algumas falhas de compilação se o SConscript não for compatível com python3.
  • PostgreSQL 10 desembarcou.
E as áreas de preparação estão cheias, abaixo os itens que estão se preparando:
  • Qt 5.9.3
  • Mais pacotes movendo para python3 (minimizando o uso do python2)
  • Linux Kernel 4.14.3
  • Implementação do libstorage-ng do YaST
Uma nota adicional para empacotadores: como você sabe, a variável suse_version é usada para distinguir entre as várias versões do openSUSE. Em 1 de dezembro de 2017, o openSUSE Tumbleweed mudou a suse_version de 1330 para 1550. Por favor, veja o anúncio de correio na lista de discussão.
 
 Com todas essas coisas agradáveis: tenha um ótimo fim de semana, divirta-se muito com o sistema de Tumbleweed atualizado.
As ISO’s são instáveis, porém se você já utiliza openSUSE Tumbleweed em seu equipamento, simplesmente deverá atualizá-lo mediante o comando “zypper up” assim seu sistema receberá as atualizações.Para realizar o download acesse o link abaixo:

Mantenha-se atualizado e você sabe divirta-se!!